Feature Request #3085

One off translations with i18n::get()

Added by Lorenzo Pisani over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:07/15/2010
Priority:NormalDue date:
Assignee:Woody Gilk% Done:

100%

Category:Core
Target version:v3.0.8
Resolution:fixed Points:

Description

so after a little debate with shadowhand and a huge misunderstanding caused by a tiny typo in the comment ... I would like to submit a feature request to translate a single string into a non-default language

if my language is set to english, I would like to be able to do I18n::get('Hello World', 'es') and get the spanish version! currently, something like this requires me to switch the site to spanish, output the phrase, and switch it back to english.

the change should be pretty simple... I will try having it withint a couple minutes actually... hopefully I don't make a fool of myself again _

setting it to 3.0.8 simply because it doesn't change any existing API... we are simply adding a parameter

Associated revisions

Revision 947c5aa1
Added by Lorenzo Pisani over 4 years ago

allowing one off translations to other languages fixes #3085

History

#2 Updated by Woody Gilk over 4 years ago

  • Status changed from New to Needs Test
  • Assignee changed from Woody Gilk to Jeremy Bush
  • % Done changed from 0 to 50
  • Resolution set to fixed

#3 Updated by Lorenzo Pisani over 4 years ago

  • Status changed from Needs Test to Closed
  • % Done changed from 50 to 100

Applied in changeset commit:"947c5aa117bf65a6c9cb8d57a2649d625c6de44d".

#4 Updated by Kiall Mac Innes over 4 years ago

  • Status changed from Closed to Needs Test
  • % Done changed from 100 to 50

Apologies - I batch closed a few tickets by mistake. Reverting.

#5 Updated by Woody Gilk about 4 years ago

  • Target version changed from v3.0.8 to v3.0.9

#6 Updated by Woody Gilk about 4 years ago

  • Target version changed from v3.0.9 to v3.0.8

#7 Updated by Woody Gilk about 4 years ago

  • Status changed from Needs Test to Closed
  • % Done changed from 50 to 100

#8 Updated by Woody Gilk about 4 years ago

  • Assignee changed from Jeremy Bush to Woody Gilk

Also available in: Atom PDF