Bug Report #3973

Kohana_Cache_File Driver errors

Added by jordan shaw over 3 years ago. Updated 6 months ago.

Status:ClosedStart date:05/06/2011
Priority:NormalDue date:
Assignee:Lorenzo Pisani% Done:

0%

Category:-
Target version:Kohana v3.x - v3.2.3
Resolution:worksforme Points:

Description

I'm getting the following errors when running tests on cache: https://gist.github.com/958937. I'm on OSX, but I've checked all my file permissions and they are all 777. It seems a recursive rmdir would be better, there's one on the http://php.net/rmdir comments.

History

#2 Updated by Jeremy Bush over 3 years ago

  • Target version set to v3.1.4

#3 Updated by Isaiah DeRose-Wilson about 3 years ago

  • Target version changed from v3.1.4 to v3.1.5

#4 Updated by Jeremy Bush over 2 years ago

  • Target version changed from v3.1.5 to v3.2.2

#5 Updated by Jeremy Bush about 2 years ago

  • Target version changed from v3.2.2 to v3.2.3

#6 Updated by Anton Shamanov 6 months ago

Fixed bugs in code `jordan shaw` and sent pull request in `3.2/develop` https://github.com/kohana/cache/pull/47

#7 Updated by Samuel Demirdjian 6 months ago

This is to report that cache module tests are running fine under:

Kohana 3.2/master
PHP 5.3.15
PHPUnit 3.7.32
OS X 10.8.4

Worth noting that I was not able to run unit tests on OS X with kohana/unittest module v.3.2. I tried with many versions of PHPUnit in vain. Tests were successfully run with PHPUnit 3.7 only when I grabbed kohana/unittest 3.3 and renamed the files to the Kohana 3.2 lowercase filename convention I am not sure if I should file a bug for kohana/unittest v. 3.2 to support PHPUnit 3.7 (as it's seems it's tagged LTS).

#8 Updated by Lorenzo Pisani 6 months ago

  • Status changed from New to Closed
  • Assignee set to Lorenzo Pisani
  • Resolution set to worksforme

I'm marking as can't reproduce since you couldn't find a way to get the same errors. This is kind of an annoying thing to test and I just want to get rid of our silly module as soon as possible anyway.

Let me know if I missed something.

Also available in: Atom PDF